Ensure You Have the Supported Versions of Commerce Cloud Endless Aisle Development Software

To ensure you have the appropriate versions of all the software required to run and develop the Endless Aisle app, see the README.md file in the Endless Aisle source code.

The version of each required element is important. If you don't have the correct version, the app might not run.

Update Appcelerator

To see what version of Appcelerator you are running:

  1. Start Appcelerator Studio.
  2. Click Appcelerator Studio in the menu.
  3. Click About Appcelerator Studio.

To get updates if your current version isn't the one specified in README.md:

  1. In Appceleraor Studio, click Help > Check for Appcelerator Updates.
  2. Click Next and follow the steps in the wizard.

Update Xcode

The version of Xcode appears on the splash screen. You can also select Xcode > About Xcode from the menu.

To revert to a previous version of Xcode:

  1. Delete the existing version of Xcode by removing Xcode from the Applications folder.
  2. Either go to the App store and download the version of Xcode you want or go to https://developer.apple.com/downloads/index.action?g=xcode, log in with your Apple developer credentials and download the version of Xcode you want.

The next step is to perform data setup and integration.

Related Links

Endless Aisle Development Environment Requirements

Apple Developer License

Approving a Development Certificate Request

Importing the Apple Distribution Certificate

Installing Xcode

Installing Appcelerator Studio.

Installing the Titanium SDK from a Terminal.